<PackageReference Include="BouncyCastle.Cryptography" Version="2.4.0" />

Org.BouncyCastle.Tls

Namespace with 160 public types

Classes

 BasicTlsPskExternal
 BasicTlsPskIdentity
 BasicTlsSrpIdentity
 ByteQueue
 ByteQueueInputStream
 ByteQueueOutputStream
 Certificate
 CertificateEntry
 CertificateRequest
 CertificateStatus
 CertificateStatusRequest
 CertificateStatusRequestItemV2
 CertificateUrl
 CertificateVerify
 ClientHello
 CombinedHash
 DefaultTlsCredentialedSigner
 DefaultTlsDHGroupVerifier
 DefaultTlsHeartbeat
 DefaultTlsKeyExchangeFactory
 DefaultTlsSrpConfigVerifier
 DigitallySigned
 DtlsClientProtocol
 DtlsRequest
 DtlsServerProtocol
 DtlsTransport
 DtlsVerifier
 HandshakeMessageInput
 HeartbeatExtension
 HeartbeatMessage
 KeyShareEntry
 NewSessionTicket
 OcspStatusRequest
 OfferedPsks
 ProtocolName
 ProtocolVersion
 PskIdentity
 PskTlsClient
 PskTlsServer
 RecordPreview
 SecurityParameters
 ServerHello
 ServerName
 ServerNameList
 ServerSrpParams
 SessionParameters
 SignatureAlgorithm
 SignatureAndHashAlgorithm
 SimulatedTlsSrpIdentityManager
 SrpTlsClient
 SrpTlsServer
 SupplementalDataEntry
 TlsClientProtocol
 TlsDHanonKeyExchange
 TlsDheKeyExchange
 TlsDHKeyExchange
 TlsECDHanonKeyExchange
 TlsECDheKeyExchange
 TlsECDHKeyExchange
 TlsException
 TlsFatalAlert
 TlsFatalAlertReceived
 TlsNoCloseNotifyException
 TlsPskKeyExchange
 TlsRsaKeyExchange
 TlsServerProtocol
 TlsSrpKeyExchange
 TlsSrpLoginParameters
 TlsTimeoutException
 TrustedAuthority
 UrlAndHash
 UseSrtpData

Enumerations

 DtlsRecordFlags

Static Classes

 TlsExtensionsUtilities

Abstract Classes

 AbstractTlsClient
 AbstractTlsKeyExchange Base class for supporting a TLS key exchange implementation.
 AbstractTlsKeyExchangeFactory Base class for supporting a TLS key exchange factory implementation.
 AbstractTlsPeer Base class for a TLS client or server.
 AbstractTlsServer Base class for a TLS server.
 AlertDescription RFC 5246 7.2.
 AlertLevel RFC 5246 7.2
 CachedInformationType
 CertChainType Implementation of the RFC 3546 3.3. CertChainType.
 CertificateCompressionAlgorithm
 CertificateStatusType
 CertificateType RFC 6091
 ChangeCipherSpec
 ChannelBinding RFC 5056
 CipherSuite RFC 2246 A.5
 CipherType RFC 2246
 ClientAuthenticationType
 ClientCertificateType
 CompressionMethod RFC 2246 6.1
 ConnectionEnd RFC 2246
 ContentType RFC 2246 6.2.1
 DefaultTlsClient
 DefaultTlsServer
 DtlsProtocol
 ECCurveType RFC 4492 5.4
 ECPointFormat RFC 4492 5.1.2
 EncryptionAlgorithm RFC 2246
 ExporterLabel RFC 5705
 ExtensionType
 HandshakeType
 HashAlgorithm RFC 5246 7.4.1.4.1
 HeartbeatMessageType RFC 6520 3.
 HeartbeatMode
 IdentifierType RFC 6066
 KeyExchangeAlgorithm RFC 2246
 KeyUpdateRequest RFC 8446 4.6.3
 MacAlgorithm RFC 2246
 MaxFragmentLength
 NamedGroup RFC 7919
 NamedGroupRole
 NameType
 PrfAlgorithm RFC 5246
 PskKeyExchangeMode
 RecordFormat
 ServerOnlyTlsAuthentication
 SignatureScheme
 SrtpProtectionProfile
 SupplementalDataType RFC 4680
 TlsDHUtilities
 TlsEccUtilities
 TlsObjectIdentifiers Object Identifiers associated with TLS extensions.
 TlsProtocol
 TlsSrpUtilities
 TlsSrtpUtilities RFC 5764 DTLS Extension to Establish Keys for SRTP.
 TlsUtilities
 UserMappingType RFC 4681

Interfaces

 DatagramReceiver
 DatagramSender
 DatagramTransport Base interface for an object sending and receiving DTLS data.
 TlsAuthentication Base interface to provide TLS authentication credentials.
 TlsClient
 TlsClientContext Marker interface to distinguish a TLS client context.
 TlsCloseable
 TlsContext Base interface for a TLS context implementation.
 TlsCredentialedAgreement Support interface for generating a secret based on the credentials sent by a TLS peer.
 TlsCredentialedDecryptor Base interface for a class that decrypts TLS secrets.
 TlsCredentialedSigner Support interface for generating a signature based on our private credentials.
 TlsCredentials Base interface for interfaces/classes carrying TLS credentials.
 TlsDHGroupVerifier Interface for verifying explicit Diffie-Hellman group parameters.
 TlsHandshakeHash Base interface for an object that can calculate a handshake hash.
 TlsHeartbeat
 TlsKeyExchange A generic interface for key exchange implementations in (D)TLS.
 TlsKeyExchangeFactory Interface for a key exchange factory offering a variety of specific algorithms.
 TlsPeer Base interface for a (D)TLS endpoint.
 TlsPsk
 TlsPskExternal
 TlsPskIdentity Processor interface for a PSK identity.
 TlsPskIdentityManager Base interface for an object that can process a PSK identity.
 TlsServer Interface describing a TLS server endpoint.
 TlsServerCertificate Server certificate carrier interface.
 TlsServerContext Marker interface to distinguish a TLS server context.
 TlsSession Base interface for a carrier object for a TLS session.
 TlsSrpConfigVerifier Interface for verifying SRP config needs to conform to.
 TlsSrpIdentity Processor interface for an SRP identity.
 TlsSrpIdentityManager Base interface for an object that can return login parameters from an SRP identity.